読者です 読者をやめる 読者になる 読者になる

Eclipse 3.4 M5 Package Builds リリース

Eclipseは3.3からJavaプログラマ用やC/C++プログラマ用などのパッケージごとにリリースがされるようになりました。先日Eclipse 3.4 M5がリリースされたとはてダに書いた記憶があるんですが、パッケージごとのリリースが行われたのは昨日みたいです。*1Eclipseのアナウンスでは3.4 M5がリリースされた直後は何もなかったんですが、要するに、パッケージリリースが行われるまで一呼吸おいたほうが試すにしても幸せだよっていうはからいなんでしょう。
id:t-wadaさん曰く、『3.4 M4は安定版じゃないけど、特に問題なく使えるよ。』という訳なので先ほど落として使い始めました。で、ちょっと残念なお知らせが。
僕が使っているパッケージはRCP/Pluginプログラマ用のEclipseなのですが、同梱されているJUnit4のバージョンが4.3.1でhumcrestもassertThatもナイバージョンなのです。*2
パンくずナビがJavaEditorにくっついたのは楽しげなので、しばらく使い続けるつもりです。

*1:[http://www.eclipse.org/community/news/eclipsenews.php:title=Eclipse News]経由で知りました。

*2:つまり3.3と変わってない