読者です 読者をやめる 読者になる 読者になる

JDKのバージョン下位互換性

Java Eclipse Plugin開発

JDKはバージョンがあがるたびに新しくクラスが追加されますが、ビルド時に確認する方法ってあるんでしょうか。やっぱりコンパイルするJDKに依存してしまうものなのでしょうか。

どういうことかっていうと、今JDK6で開発しているプラグインがJDK5でも動くことを保障するには、JDK5へ環境を移さないとすべて確認できないのかということです。例えばJDK6からCookieManagerの実装クラスが提供されるようになりましたが、ということはJDK5だとCookieManagerの実装クラスは提供されていないということで、それなりの対応をしなければならないと思いますが、具体的に何をしたらいいのかをわかるために有用なツールとかないもんかなと。実験的な意味で始めたプロジェクトなんで、下位互換性を気にしなくてもいいかと思っててもやっぱり気になるもんですよ。